Slowed performance

Incident Report for ClickFunnels

Resolved

This incident has been resolved.
Posted Dec 18, 2025 - 13:04 MST

Monitoring

Things are back to normal and in-app pages are loading as expected. Our team is continuing to monitor the system closely and is still investigating the underlying cause so we can prevent similar issues in the future.
Posted Dec 18, 2025 - 10:25 MST

Investigating

We’re currently investigating an issue that may cause some in-app pages to load more slowly than usual. The application remains fully available and usable, but you may notice delayed performance while navigating certain areas.

Our team is actively reviewing to identify the root cause and is working to address the slowdown as quickly as possible. We’ll continue to share updates here as we learn more and make progress.

We will continue to update this as things progress.
Posted Dec 18, 2025 - 09:52 MST
This incident affected: Dashboards.