Account Creation Issues

Incident Report for ClickFunnels

Resolved

This incident has been resolved.
Posted Feb 28, 2025 - 11:58 MST

Investigating

We are currently investigating an issue with the account creation process.
Posted Feb 28, 2025 - 11:33 MST
This incident affected: Funnels.